Меню Закрыть

Huawei маршрутизация между vlan

Маршрутизация vlan при помощи коммутаторов

Обычным способом маршрутизации между vlan при помощи маршрутизатора. Но у этого способа есть существенный недостаток – для него надо иметь маршрутизатор. В этой статье мы расскажем, как организовать маршрутизацию между vlan без маршрутизатора. Единственная оговорка – для этого нам понадобится коммутатор 3-го уровня, обладающий частью функций маршрутизации.

Данная схема маршрутизации изображена на следующем рисунке:

Принцип маршрутизации между vlan на коммутаторе

Построим данную сеть при помощи программы Packet Tracer :

Наша схема в Packet Tracer

Настроим сеть следующим образом:

Switch(config)# interface fastEthernet 0/1

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 2

Switch(config)#interface fastEthernet 0/2

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 3

Switch(config)#interface vlan 2

Switch(config)#interface vlan 3

Здесь мы создаем компьютер PC 0, задаем ему IP 192.168.2.2 с маской 255.255.255.0 и шлюзом 192.168.2.1.

Создаем компьютер PC 1, задаем адрес 192.168.3.1 с маской 255.255.255.0 и шлюзом 192.168.3.1.

Создаем сети vlan 2, vlan 3, назначаем им соответственно порты Fa 0/1 и Fa 0/2.

Для проверки работоспособности нашей схемы пропингуем с компьютера PC 0 другой компьютер – PC 1. Пинги не проходят, потому что компьютеры находятся в разных виртуальных сетях с разной адресацией.

Для настройки маршрутизации между ними, выполним следующие инструкции:

Switch(config)#interface vlan 2

Switch(config-if)#ip address 192.168.2.1 255.255.255.0

Switch(config)#interface vlan 3

Switch(config-if)#ip address 192.168.3.1 255.255.255.0

Этими командами мы определили IP адреса vlan интерфейсам коммутатора, затем командой « ip routing » активировали маршрутизацию между ними. Так же можно посмотреть таблицу маршрутизации для интерфейса при помощи команды « show ip route ». Ответ коммутатора будет выглядеть так:

Читайте также:  Как перезагрузить айфон через компьютер

Вывод команды show ip route

Повторите попытку пинга самостоятельно.

Как вы могли убедится, пинг проходит успешно, а это значит, что мы настроили маршрутизацию между vlan сетями.

Как видно, маршрутизация при помощи коммутаторов похожа на маршрутизацию при помощи роутера, но есть ряд отличий. При использовании коммутаторов приходится присваивать IP адреса vlan интерфейсам, а не субинтерфейсам, как в случае с маршрутизатором. Кроме того приходится включать маршрутизацию между коммутаторами, когда в случае с маршрутизатором она выполняется по умолчанию.

На этом всё, до следующих встреч.

Конечно, для разных групп клиентов
у нас разные цены.

Розница

Прежде чем просить скидку — сравните наши цены с ценами в других местах. Как правило наши (даже розничные!) цены заметно ниже.

Партнер

Мы любим операторов связи. Поэтому если вы оператор
связи — вы сразу и безоговорочно имеете право на «вторую колонку».
Если вы оформляете разовый заказ на сумму более 200 т.р. — вы безусловно крупный клиент. Мы любим крупных клиентов, поэтому сразу предоставим вам «партнерскую» колонку.
Если вы покупаете ежемесячно на сумму не менее 30 т.р. —
вы стабильный клиент. Конечно, мы любим стабильность.
Вам будет предоставлена партнерская цена.

Дилер

Если у вас есть разовый заказ на сумму более 400 т.р. —
у вас есть право получить на него дилерскую цену. Если оборот вашей компании, за последние 6 месяцев, составляет 600 т.р. — вы имеете право на дилерскую колонку в течении всего следующего года.

Продолжая просмотр сайта и(или) нажимая X , я соглашаюсь с использованием файлов cookie владельцем сайта в соответствии с Политикой в отношении файлов cookie в том числе на передачу данных, указанных в Политике, третьим лицам (статистическим службам сети Интернет), в соответствии с Пользовательским соглашением >X

Читайте также:  Как включить на айпаде поворот экрана

Для предприятий

Продукты, решения и услуги для предприятий

Интернет-магазин

Смартфоны, ПК и планшеты, носимые устройства и многое другое

Корпоративный сайт

О компании Huawei, пресса, события и многое другое

HUAWEI – одна из крупнейших китайских компаний в сфере телекоммуникаций. Основана в 1988 году.

Компания HUAWEI достаточно недавно вышла на российский рынок сетевого оборудования уровня Enterprise. С учётом тенденции тотальной экономии, на нашем предприятии очень остро встал вопрос о подборе достойной замены оборудованию Cisco.
В статье я попытаюсь рассмотреть базовые аспекты настройки сервисов коммутации и маршрутизации оборудования HUAWEI на примере коммутатора Quidway серии 5300.

Глобальные команды, режимы работы, cходства и различия с CLI CISCO.

Оборудование HUAWEI, построенное на базе операционной системы VRP, имеет cisco-like интерфейс командной строки. Принципы остаются теми же самыми, меняется только синтаксис.
В CLI оборудования HUAWEI существуют 2 режима командного интерфейса:

  1. system-view – аналог цисковского режима конфигурирования conf t. В этом режиме приглашение командной строки выглядит как [Switch].
  2. user-view – аналог цисковского непривилегированного режима. Режим приглашения выглядит так: .

В отличие от непривилегированного режима Cisco из user-view доступны многие функции, в частности можно ресетнуть запущенные процессы. Подключения по telnet и ssh так же доступны только из user-view.
После некоторых претензий со стороны компании Cisco Systems, в ОС VRP были заменены часть служебных слов. Таблица соответствия некоторых служебных слов CLI представлена ниже.

Cisco HUAWEI
show display
running-configuration current-configuration
clear reset
configure terminal system-view
write save
quit exit
no undo

Основные команды:
  • system-view – переход из user-view в привилегированный режим system-view;
  • save – запись текущих настроек в энергонезависимую память устройства;
  • display current-configuration – вывод текущего файла конфигурации
  • display current-configuration configuration XXXX – вывод настроек секции XXXX.
  • display this – вывод конфигурации текущей секции;
  • quit – выход из текущей секции в родительскую.
Читайте также:  Цена моего аккаунта steam

Настройка vlan интерфейсов, режимы работы физических портов коммутатора

Создание vlan

Для создания vlan как сущности, на коммутаторе в режиме system-view выполняется команда vlan XXX, где XXX – номер vlan.

Vlan создан. Так же командой description можно задать описание или название vlan. В отличие от Cisco имя не является обязательным атрибутом при создании vlan.

Для передачи созданых vlan в пределах локальной сети используется протокол GVRP. Включается он командой gvrp в режиме system-view.

Так же gvrp должен быть разрешён на интерфейсе:

Совместимости с Cisco VTP (vlan transfer protocol) нет и быть не может.

Создание vlan интерфейса.

В отличие от Cisco, маску можно писать сокращённо. Очень удобно.
Думаю, что комментарии излишни.

Режимы работы портов

Собственно, ничего нового. Существуют два основных режима работы порта: access и trunk.
Режим trunk
Настройка порта:

В отличие от коммутаторов Cisco, по-умолчанию, все vlan запрещены и их необходимо принудительно разрешить командой port trunk allow-pass vlan.
Нетэггированный native vlan на порту включается командой:

Настройка eth-trunk

Настройка STP

Для тестирование STP были соединены коммутаторы Cisco 2960 и HUAWEI Quidway S5328C-EI.
Для включения STP на коммутаторе необходимо в режиме system-view ввести команду

По умолчанию, приоритет коммутатора HUAWEI, так же как и коммутатора Cisco равен 32768.
Просмотр информации о текущем состоянии портов:

Видно, что один из портов заблокирован, т. к. приоритет коммутатора Cisco оказался больше.
Просмотр глобальной информации об STP:

Изменим приоритет коммутатора HUAWEI. Сделаем его наименьшим: 4096.

Посмотрим, что порт разблокировался:

Общая информация об STP:

Статическая маршрутизация

Статические маршруты прописываются точно так же, как на оборудовании Cisco:

Просмотр таблицы маршрутизации:

На этом всё.
Если уважаемое сообщество заинтересуется материалом, планирую продолжить освещать настройку оборудования HUAWEI. В следующей статье рассмотрим настройку динамической маршрутизации.

Рекомендуем к прочтению

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

*

code

Adblock
detector